Results 1 to 2 of 2
  1. #1
    Martin Fiedler

    I'm trying to use a Sony Ericsson T610 mobile phone as a GPRS modem
    via IrDA under Linux. But for some reason, the virtual serial device
    is not working, i.e. I can not send any (AT) command to the phone via
    minicom, for example.

    The IrDA subsystem is running, irattach -s is started, and irdadump
    and /proc/net/irda/discovery show up the T610. The ircomm and
    ircomm-tty modules are loaded as well, but no program can use the
    /dev/ircomm0 device. I tried various serial port settings in minicom,
    but none worked.

    irdadump shows things like:
    > 19:26:55.875292 xid:cmd fba81c40 > ffffffff S=6 s=* lappi hint=8404 [ Computer IrCOMM ] (22)
    > 19:27:10.501605 xid:rsp fba81c40 < 5b2d047e S=6 s=1 T610 series hint=9124 [ PnP Modem IrCOMM IrOBEX ] (28)
    > 19:27:11.515453 snrm:cmd ca=fe pf=1 fba81c40 > 5b2d047e new-ca=e4
    > LAP QoS: Baud Rate=4000000bps Max Turn Time=500ms Data Size=2048B Window Size=1 Add BOFS=0 Min Turn Time=1000us Link Disc=12s (33)
    > 19:27:11.622819 ua:rsp ca=e4 pf=1 fba81c40 < 5b2d047e
    > LAP QoS: Baud Rate=115200bps Max Turn Time=500ms Data Size=256B Window Size=3 Add BOFS=0 Min Turn Time=50us Link Disc=12s (31)
    > 19:27:11.635714 i:cmd > ca=e4 pf=1 nr=0 ns=0 LM slsap=4e dlsap=00 CONN_CMD (6)
    > 19:27:11.642659 i:rsp < ca=e4 pf=1 nr=1 ns=0 LM slsap=00 dlsap=4e CONN_RSP (6)
    > 19:27:11.642710 i:cmd > ca=e4 pf=1 nr=1 ns=1 LM slsap=4e dlsap=00 GET_VALUE_BY_CLASS: "IrDA:IrCOMM" "Parameters" (28)
    > 19:27:11.651094 i:rsp < ca=e4 pf=1 nr=2 ns=1 LM slsap=00 dlsap=4e GET_VALUE_BY_CLASS: Success
    > 19:27:11.651229 i:cmd > ca=e4 pf=0 nr=2 ns=2 LM slsap=4e dlsap=00 DISC (6)

    (irrelevant lines removed)

    The really strange thing is that a friend's mobile phone, a Siemens
    ME45, works perfectly with the same setup. Also, my T610 works well
    under Windows, so neither the phone nor the IrDA subsystem are broken.
    It's just that I can't connect the T610 to Linux' IrDA.

    Does anybody have suggestions how to resolve this problen?

    Martin J. Fiedler

    See More: SE T610, Linux, and IrDA

  2. #2
    Mikko Rapeli

    Re: SE T610, Linux, and IrDA

    Perhaps the T610 is a buggy one; try the options suggested by Jean
    Tourrilhes on his page (search for "ericsson" on the page ):
    # echo 1000 > /proc/sys/net/irda/min_tx_turn_time
    # echo 1 > /proc/sys/net/irda/max_tx_window


  • Phones Discussed Above

    Sony Ericsson T610 More Sony Ericsson T610 topics Sony Ericsson Forum Reviews
  • Similar Threads