Results 1 to 2 of 2
  1. #1
    Slon
    Guest
    Device: Nokia E50-1
    OS: Symbian 3rd ED futured pack 1 (aka v9.1)

    During instaling JAR App (J2ME) after ~80% i had a error "Unable To
    Install" !!!

    The problem is ... that Installer have a bug, i think so !!! Than U
    install JAR from Internet by JAD and connection is lost, installation
    is interapted AND U are in trouble !!!
    After this U can't install any more JAR and can't see in APP.Manager Ur
    allready installed JARs (few still are)

    Do u know this !?! Do U know which files are responsyble for that !?!
    Any ideas =) ???

    One more thing .. i found file Z:\System\swipolicy.ini

    AllowUnsigned = false ***IT'S MY NOTES - THERE I MUST CHANGED IT. IN
    APP.Manager - INSTALL ALL IS SET TO TRUE - END OF MINE***
    MandatePolicies = false
    MandateCodeSigningExtension = false
    Oid = 1.2.3.4.5.6
    Oid = 2.3.4.5.6.7
    DRMEnabled = true
    DRMIntent = 3
    OcspMandatory = false
    OcspEnabled = true
    AllowGrantUserCapabilities = true
    AllowOrphanedOverwrite = true
    UserCapabilities = NetworkServices LocalServices ReadUserData
    WriteUserData UserEnvironment
    AllowPackagePropagate = true
    SISCompatibleIfNoTargetDevices = false
    RunWaitTimeoutSeconds = 600
    AllowRunOnInstallUninstall = false
    DeletePreinstalledFilesOnUninstall = true




    See More: Unable To Install




  2. #2
    SlonUA
    Guest

    Re: Unable To Install

    SOLVED by ME !!!

    Reason: during instalation JAR process was interapted by anything
    (restart, lost power, lost connection, etc.) Result of it is bad REG
    creation !!!

    Look into "C:\System\Install\Registry\" .. U will find files like
    "*.reg" (ex. "1013EF8D.reg").

    Normal file must be content next (example of "100FF7C1.reg"):
    °C:\private\102033E6\MIDlets\[100ff7c1]\ uids @appUid:270479035?? C
    HWarDiaryBurma
    [NP] Rovio °· ·· -· = )
    c:\private\102033e6\midlets\[100ff7c1]\1149154 895_war_diary_burma.jar
    µ " ".
    µ J 4WarDiaryBurma

    And, corrupted file look like:
    ? ,??tŠ??? ??? e,(?-P? ?pl?R)‹??3?€?T?›?
    ??"M% ?? D
    †I¶3?!r?j:??k??/?™:Z?????#?€-m?? ‡??...‹?J›f

    .... or sth else (means not logical organization as first)!!!

    Symbian is smart a little ... before U try install new JAR App, it
    rescan system for REG, then it try to read corrupted file, it just stop
    a process of installation with primitive error "Unable to Install" !!!
    Also if u look in App.Manager .. not all installed JAR are shown !!!

    Solution is: JUST DELETE THIS CORRUPTED FILE !!!

    Slon wrote:
    > Device: Nokia E50-1
    > OS: Symbian 3rd ED futured pack 1 (aka v9.1)
    >
    > During instaling JAR App (J2ME) after ~80% i had a error "Unable To
    > Install" !!!
    >
    > The problem is ... that Installer have a bug, i think so !!! Than U
    > install JAR from Internet by JAD and connection is lost, installation
    > is interapted AND U are in trouble !!!
    > After this U can't install any more JAR and can't see in APP.Manager Ur
    > allready installed JARs (few still are)
    >
    > Do u know this !?! Do U know which files are responsyble for that !?!
    > Any ideas =) ???
    >
    > One more thing .. i found file Z:\System\swipolicy.ini
    >
    > AllowUnsigned = false ***IT'S MY NOTES - THERE I MUST CHANGED IT. IN
    > APP.Manager - INSTALL ALL IS SET TO TRUE - END OF MINE***
    > MandatePolicies = false
    > MandateCodeSigningExtension = false
    > Oid = 1.2.3.4.5.6
    > Oid = 2.3.4.5.6.7
    > DRMEnabled = true
    > DRMIntent = 3
    > OcspMandatory = false
    > OcspEnabled = true
    > AllowGrantUserCapabilities = true
    > AllowOrphanedOverwrite = true
    > UserCapabilities = NetworkServices LocalServices ReadUserData
    > WriteUserData UserEnvironment
    > AllowPackagePropagate = true
    > SISCompatibleIfNoTargetDevices = false
    > RunWaitTimeoutSeconds = 600
    > AllowRunOnInstallUninstall = false
    > DeletePreinstalledFilesOnUninstall = true





  • Similar Threads