Results 1 to 4 of 4
  1. #1
    Garr
    Guest
    I got the new VGA 1000 on Monday of last week. Had it one day and it locked
    up. I would turn on the phone and the Sprint sign on screen would show and
    then it would lock. Removing battery did nothing.

    Took it back and got another one. It lasted three days and did the exact
    same thing. So I am now on the 3rd one in less than a week. Personally I
    think if has something to do with the charging of the unit. After taking it
    off the charger the same thing happened on both units.







    See More: VGA/1000 (Samsung A620) Buyers Beware




  2. #2
    Thomas T. Veldhouse
    Guest

    Re: VGA/1000 (Samsung A620) Buyers Beware


    "Garr" <[email protected]> wrote in message
    news:[email protected]
    > I got the new VGA 1000 on Monday of last week. Had it one day and it

    locked
    > up. I would turn on the phone and the Sprint sign on screen would show

    and
    > then it would lock. Removing battery did nothing.
    >
    > Took it back and got another one. It lasted three days and did the exact
    > same thing. So I am now on the 3rd one in less than a week. Personally I
    > think if has something to do with the charging of the unit. After taking

    it
    > off the charger the same thing happened on both units.
    >


    Bet on software. Samsung seems to release buggy software with their new
    phones. It seems to take many iterations to get it right.

    Tom Veldhouse





  3. #3
    Brooose
    Guest

    Re: VGA/1000 (Samsung A620) Buyers Beware


    I've had mine for a week and no crashes. I only had the "no calls,
    vision active bug" once. Great phone so far!

    --
    Posted at SprintUsers.com - Your place for everything Sprint PCS
    Free wireless access @ www.SprintUsers.com/wap




  4. #4
    Orac
    Guest

    Re: VGA/1000 (Samsung A620) Buyers Beware

    In article <[email protected]>,
    "Thomas T. Veldhouse" <[email protected]> wrote:

    > "Garr" <[email protected]> wrote in message
    > news:[email protected]
    > > I got the new VGA 1000 on Monday of last week. Had it one day and it

    > locked
    > > up. I would turn on the phone and the Sprint sign on screen would show

    > and
    > > then it would lock. Removing battery did nothing.
    > >
    > > Took it back and got another one. It lasted three days and did the exact
    > > same thing. So I am now on the 3rd one in less than a week. Personally I
    > > think if has something to do with the charging of the unit. After taking

    > it
    > > off the charger the same thing happened on both units.
    > >

    >
    > Bet on software. Samsung seems to release buggy software with their new
    > phones. It seems to take many iterations to get it right.


    Indeed. My A500 suffered from many of the bugs described here on this
    newsgroup. However, after I got the WD29 update 3 weeks ago (which is
    the second update Samsung has released, I believe), it's worked
    flawlessly.
    --
    Orac |"A statement of fact cannot be insolent."
    |
    |"If you cannot listen to the answers, why do you
    | inconvenience me with questions?"



  • Similar Threads