Recently i bought an NEC 535m to use with t-mobile. The person i bought it from claimed it was unlocked, but when i put my sim card in all i got was "error reading SIM Remove and Reinsert Battery". I assumed the that the person had not unlocked the cell phone as claimed, so i bought a usb cable for it, downloaded NecTalk, and tried to unlock it - the unlocking kept giving me errors, so i assumed the phone was not unlockable and sent it back to the person i bought it from screaming.

I was given a refund and i bought another unlocked 535m another unlocked 535m from a different person. The same exact thing happened with this phone so i thought maybe it was my SIM card and had t-mobile send me another one - i got the new one and registered it, same error. Around the same time though, my mother switched from At&t to t-mobile and when she started the account she got a free cell phone. Out of curiosity i too her SIM card and put it in the 535M, and surprisingly it worked. Next i put my SIM card in her phone and it worked fine.

Is there sometime i'm missing here?

Thanks in advance for the help,


See More: Nec 535m and t-mobile