1. #1
    wildetudor is offline
    wildetudor's Avatar

    49 - liked 1 times
    Hi everyone,

    Being unpatient for v32.2.001 to be released for my N95 8GB product code (0561948), I changed (using Nemesis Service Suite) my handset's product code to 0558696, for which the said firmware version has been available for a few days now.

    Having done that, I opened Nokia Software Updater (NSU), and sure enough, v32 was now available for update. After the update was downloaded, the installation began, and an "Estimated time left: 15 minutes" progress bar was displayed. A few minutes later, the estimated time was still 15 minutes, and at one point, NSU produced the following screen:

    Device Recovery

    Nokia Software Updater has lost its connection with your device. Follow these steps to help reconnect your device:
    1. Remove the battery, charger and USB cable from your device.
    2. Re-insert the USB cable, then the battery and finally the charger.
    3. Press the device's power button for 1 second.
    4. Click 'Retry' below to continue updating, or click 'Cancel' to stop the updating procedure.'

    Looking at my phone, everything appeared to be OK. I disconnected the USB cable, turned off the phone, pulled the battery out and then put it back in after a few seconds, and then tried to switch the phone on. The phone would not start, which had me really worried since I knew serious damage can be done by a failed firmware upgrade. After a few more trials with the Power button, however, I got it to turn on. Checking *#0000#, I could see the firmware version was still the same (bloody 31.2.008!), so I hit the Retry button in NSU. The same "Device Recovery" screen came back, however, after a few minutes.

    I then tried everything else I could think of, including
    - switching off Bluetooth connectivity on both computer and phone
    - restarting the computer
    - restarting the phone (with baterry pull)
    - starting the update all over again on a different computer that had not previously had any Nokia software installed; the results were exactly the same, i.e. I could not get past the "Device Recovery" screen.

    I never had any problems with the USB cable connectivity of my phone in the past. Could this whole thing be because of the product code change? I would very much appreciate any suggestions!

    See More: Cannot upgrade firmware: "Device Recovery" screen in NSU
    Last edited by wildetudor; 08-11-2009 at 08:49 AM.

  • Similar Threads

  • Quick Reply Quick Reply

    If you are already a member, please login above.