On Cell Phone Forums
  1. #1
    ponesma
    ponesma is offline
    Newbie

    Location
    Elgin Illinois
    Posts
    3
    I have had this phone for about 2 months and have not had any problems. This weekend the battery died ad I went to plug it in to charge it and I got nothing. I thought maybe my charger was bad, so I went to my car to use the car charger and I also got nothing. I moved the plug around and it would start to charge. But I can not just plug it in and it will charge, now I have to move the connector around until it starts to charge. The I can not touch it until it is fully charged. So it seems like there is something not making contact on the charge port on the phone. This just not seem right.

    Has anyone else had this problem?

    Mike


    See More: T519 - Charging Problem




  2. #2
    bigjon
    bigjon is offline
    Newbie

    Posts
    2

    Re: T519 - Charging Problem

    Did you ever figure out the problem? I have a similar issue with my M500



  3. #3
    ponesma
    ponesma is offline
    Newbie

    Location
    Elgin Illinois
    Posts
    3

    Re: T519 - Charging Problem

    bigjon, I could not figure out what the problem was other then the fact that the plug looks VERY fagile. They wanted $100 to fix it, so I just bought another phone. Seems like a REALLY bad design, but my Katalyst has a different charging port.

    Good Luck



  • Similar Threads







  • Quick Reply Quick Reply

    If you are already a member, please login above.